Symfony PHP framework

Alhamdulillah, tiga hari berturut-turut bisa menulis artikel kembali tentang PHP framework dan hari ini saya coba menulis tentang instalasi Symfony framework ( https://symfony.com/ )

symfony-framework-01

Ada beberapa cara instalasi Symfony framework ini, diantaranya dengan ‘Symfony installer’ adalah executable PHP 5.4 yang kompatibel yang perlu diinstal di sistem Anda hanya satu kali.

Untuk pengguna Linux seperti saya, perintahnya  :

#Linux
$ sudo mkdir -p /usr/local/bin
$ sudo curl -LsS https://symfony.com/installer -o /usr/local/bin/symfony
$ sudo chmod a+x /usr/local/bin/symfony

Kalau berhasil akan terlihat file installer ‘symfony’ pada folder /usr/local/bin

Selanjutnya tinggal kita buat proyek baru, saya memberinamanya : mysymfony1 (silahkan sesuaikan sendiri )

$ symfony new mysymfony1

Hasilnya :

symfony-framework-03-new
Membuat proyek baru dengan Symfony  2.8

Apabila versi PHP yang ada di komputer kita tidak mendukung versi symfony terbaru maka akan keluar peringatan seperti ini:

symfony-framework-02-php-version
Symfony versi 3.3.2 , membutuhkan minimal PHP versi 5.5.9. Sementara di komputer saya hanya ada PHP versi 5.4.45. Jadi saya install Symfony versi 2.8

Symfony versi 2.8.22 berhasil di install.

  • Buka terminal lagi , pindah ke folder proyek yang baru di buat
  • Kemudian aktifkan php webserver-nya.

$ cd mysymfony1
$ php app/console server:start

Screenshot from 2017-06-30 10:59:49

Dari gambar di atas terlihat web server sudah aktif di localhost pada port 8000.

Buka browser kesayangan anda, ketik : http://localhost:8000

Screenshot from 2017-06-30 11:08:41

Berhasil di install dan di jalankan.

Salam.

Iklan